libgabe: Update to 1.0
Switched to codeload to simplify the Makefile Added PKG_BUILD_PARALLEL for faster compilation. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
9e25a6e528
commit
0447085fb3
2 changed files with 58 additions and 10 deletions
|
@ -1,23 +1,20 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libgabe
|
||||
PKG_VERSION:=0.99
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/schanzen/libgabe/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=2a8c151a90c9ad8eaad073c8ad1482d66875e3433b0b4fd1e08424c0fc89e877
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
|
||||
PKG_LICENSE:=GPLv2
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_URL:=https://github.com/schanzen/libgabe.git
|
||||
PKG_SOURCE_VERSION:=a082729326155207312a5fc280d17844b69450f2
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.xz
|
||||
PKG_MIRROR_HASH:=74046e8c5657d2e5bcdc0e806983ad4e205a0ed0945f8ab802d7fe564c32e9bd
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
|
51
libs/libgabe/patches/010-shared-library.patch
Normal file
51
libs/libgabe/patches/010-shared-library.patch
Normal file
|
@ -0,0 +1,51 @@
|
|||
From 9a0e73c5f6cbcf825eced89d26273a24f7266522 Mon Sep 17 00:00:00 2001
|
||||
From: "Schanzenbach, Martin" <martin.schanzenbach@aisec.fraunhofer.de>
|
||||
Date: Sun, 30 Sep 2018 20:38:37 +0200
|
||||
Subject: [PATCH] shared library
|
||||
|
||||
---
|
||||
Makefile.in | 13 ++++++-------
|
||||
1 file changed, 6 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index f23bf90..c8c19fa 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -18,13 +18,12 @@ LDFLAGS = @LDFLAGS@ \
|
||||
|
||||
DISTNAME = @PACKAGE_TARNAME@-@PACKAGE_VERSION@
|
||||
|
||||
-all: libgabe.a TAGS
|
||||
+all: libgabe.so TAGS
|
||||
|
||||
# compilation and library making
|
||||
|
||||
-libgabe.a: core.o misc.o
|
||||
- rm -f $@
|
||||
- ar rc $@ $^
|
||||
+libgabe.so: core.o misc.o
|
||||
+ $(CC) -shared -o $@ $^
|
||||
|
||||
# test: test.o libgabe.a
|
||||
# $(CC) -o $@ $(LDFLAGS) $^
|
||||
@@ -44,14 +43,14 @@ dist: AUTHORS COPYING INSTALL NEWS README \
|
||||
tar zc $(DISTNAME) > $(DISTNAME).tar.gz
|
||||
rm -rf $(DISTNAME)
|
||||
|
||||
-install: libgabe.a gabe.h
|
||||
+install: libgabe.so gabe.h
|
||||
$(top_srcdir)/mkinstalldirs -m 755 $(DESTDIR)$(libdir)
|
||||
$(top_srcdir)/mkinstalldirs -m 755 $(DESTDIR)$(includedir)
|
||||
- $(top_srcdir)/install-sh -m 755 libgabe.a $(DESTDIR)$(libdir)
|
||||
+ $(top_srcdir)/install-sh -m 755 libgabe.so $(DESTDIR)$(libdir)
|
||||
$(top_srcdir)/install-sh -m 644 gabe.h $(DESTDIR)$(includedir)
|
||||
|
||||
uninstall:
|
||||
- /bin/rm -f $(DESTDIR)$(libdir)/libgabe.a
|
||||
+ /bin/rm -f $(DESTDIR)$(libdir)/libgabe.so
|
||||
/bin/rm -f $(DESTDIR)$(includedir)/gabe.h
|
||||
|
||||
# development and meta stuff
|
||||
--
|
||||
2.17.1
|
||||
|
Loading…
Reference in a new issue