bluez: Update to 5.64, update/refresh patches
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
(cherry picked from commit d3cdfa3c30
)
This commit is contained in:
parent
30c39ca1d7
commit
044425dc4b
4 changed files with 32 additions and 14 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=bluez
|
PKG_NAME:=bluez
|
||||||
PKG_VERSION:=5.62
|
PKG_VERSION:=5.64
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@KERNEL/linux/bluetooth/
|
PKG_SOURCE_URL:=@KERNEL/linux/bluetooth/
|
||||||
PKG_HASH:=38090a5b750e17fc08d3e52178ed8d3254c5f4bd2c48830d5c1955b88e3bc0c2
|
PKG_HASH:=ae437e65b6b3070c198bc5b0109fe9cdeb9eaa387380e2072f9de65fe8a1de34
|
||||||
|
|
||||||
PKG_LICENSE:=GPL-2.0-or-later
|
PKG_LICENSE:=GPL-2.0-or-later
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/Makefile.in
|
--- a/Makefile.in
|
||||||
+++ b/Makefile.in
|
+++ b/Makefile.in
|
||||||
@@ -3342,7 +3342,7 @@ unit_tests = $(am__append_54) unit/test-
|
@@ -3479,7 +3479,7 @@ unit_tests = $(am__append_55) unit/test-
|
||||||
@CLIENT_TRUE@ client/admin.c
|
@CLIENT_TRUE@ client/admin.c
|
||||||
|
|
||||||
@CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
@CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
||||||
|
@ -9,7 +9,7 @@
|
||||||
|
|
||||||
@ZSH_COMPLETIONS_TRUE@zshcompletiondir = $(ZSH_COMPLETIONDIR)
|
@ZSH_COMPLETIONS_TRUE@zshcompletiondir = $(ZSH_COMPLETIONDIR)
|
||||||
@ZSH_COMPLETIONS_TRUE@dist_zshcompletion_DATA = completion/zsh/_bluetoothctl
|
@ZSH_COMPLETIONS_TRUE@dist_zshcompletion_DATA = completion/zsh/_bluetoothctl
|
||||||
@@ -3575,7 +3575,7 @@ unit_tests = $(am__append_54) unit/test-
|
@@ -3722,7 +3722,7 @@ unit_tests = $(am__append_55) unit/test-
|
||||||
|
|
||||||
@MESH_TRUE@@TOOLS_TRUE@tools_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
@MESH_TRUE@@TOOLS_TRUE@tools_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
||||||
@MESH_TRUE@@TOOLS_TRUE@ lib/libbluetooth-internal.la \
|
@MESH_TRUE@@TOOLS_TRUE@ lib/libbluetooth-internal.la \
|
||||||
|
@ -18,16 +18,25 @@
|
||||||
|
|
||||||
@MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgclient_SOURCES = tools/mesh-cfgclient.c \
|
@MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgclient_SOURCES = tools/mesh-cfgclient.c \
|
||||||
@MESH_TRUE@@TOOLS_TRUE@ tools/mesh/model.h tools/mesh/config-model.h \
|
@MESH_TRUE@@TOOLS_TRUE@ tools/mesh/model.h tools/mesh/config-model.h \
|
||||||
@@ -3646,7 +3646,7 @@ unit_tests = $(am__append_54) unit/test-
|
@@ -3736,7 +3736,7 @@ unit_tests = $(am__append_55) unit/test-
|
||||||
|
@MESH_TRUE@@TOOLS_TRUE@ mesh/crypto.h mesh/crypto.c
|
||||||
|
|
||||||
|
@MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgclient_LDADD = lib/libbluetooth-internal.la src/libshared-ell.la \
|
||||||
|
-@MESH_TRUE@@TOOLS_TRUE@ $(ell_ldadd) -ljson-c -lreadline
|
||||||
|
+@MESH_TRUE@@TOOLS_TRUE@ $(ell_ldadd) -ljson-c -lreadline -lncurses
|
||||||
|
|
||||||
|
@MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgtest_SOURCES = tools/mesh-cfgtest.c
|
||||||
|
@MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgtest_LDADD = lib/libbluetooth-internal.la src/libshared-ell.la \
|
||||||
|
@@ -3793,7 +3793,7 @@ unit_tests = $(am__append_55) unit/test-
|
||||||
@READLINE_TRUE@ tools/obex-client-tool.c
|
@READLINE_TRUE@ tools/obex-client-tool.c
|
||||||
|
|
||||||
@READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
|
@READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
|
||||||
-@READLINE_TRUE@ $(GLIB_LIBS) -lreadline
|
-@READLINE_TRUE@ src/libshared-glib.la $(GLIB_LIBS) -lreadline
|
||||||
+@READLINE_TRUE@ $(GLIB_LIBS) -lreadline -lncurses
|
+@READLINE_TRUE@ src/libshared-glib.la $(GLIB_LIBS) -lreadline -lncurses
|
||||||
|
|
||||||
@READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
|
@READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
|
||||||
@READLINE_TRUE@ tools/obex-server-tool.c
|
@READLINE_TRUE@ tools/obex-server-tool.c
|
||||||
@@ -3655,15 +3655,15 @@ unit_tests = $(am__append_54) unit/test-
|
@@ -3804,15 +3804,15 @@ unit_tests = $(am__append_55) unit/test-
|
||||||
@READLINE_TRUE@tools_bluetooth_player_SOURCES = tools/bluetooth-player.c
|
@READLINE_TRUE@tools_bluetooth_player_SOURCES = tools/bluetooth-player.c
|
||||||
@READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
|
@READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
|
||||||
@READLINE_TRUE@ src/libshared-glib.la \
|
@READLINE_TRUE@ src/libshared-glib.la \
|
||||||
|
@ -36,8 +45,8 @@
|
||||||
|
|
||||||
@READLINE_TRUE@tools_obexctl_SOURCES = tools/obexctl.c
|
@READLINE_TRUE@tools_obexctl_SOURCES = tools/obexctl.c
|
||||||
@READLINE_TRUE@tools_obexctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
@READLINE_TRUE@tools_obexctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
||||||
-@READLINE_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
|
-@READLINE_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
|
||||||
+@READLINE_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
|
+@READLINE_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
|
||||||
|
|
||||||
@READLINE_TRUE@tools_btmgmt_SOURCES = tools/btmgmt.c src/uuid-helper.c client/display.c
|
@READLINE_TRUE@tools_btmgmt_SOURCES = tools/btmgmt.c src/uuid-helper.c client/display.c
|
||||||
@READLINE_TRUE@tools_btmgmt_LDADD = lib/libbluetooth-internal.la src/libshared-mainloop.la \
|
@READLINE_TRUE@tools_btmgmt_LDADD = lib/libbluetooth-internal.la src/libshared-mainloop.la \
|
||||||
|
@ -46,7 +55,7 @@
|
||||||
|
|
||||||
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
|
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
|
||||||
@DEPRECATED_TRUE@@READLINE_TRUE@ attrib/gattrib.c btio/btio.c \
|
@DEPRECATED_TRUE@@READLINE_TRUE@ attrib/gattrib.c btio/btio.c \
|
||||||
@@ -3672,7 +3672,7 @@ unit_tests = $(am__append_54) unit/test-
|
@@ -3821,7 +3821,7 @@ unit_tests = $(am__append_55) unit/test-
|
||||||
@DEPRECATED_TRUE@@READLINE_TRUE@ client/display.h
|
@DEPRECATED_TRUE@@READLINE_TRUE@ client/display.h
|
||||||
|
|
||||||
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
|
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
|
||||||
|
@ -55,3 +64,12 @@
|
||||||
|
|
||||||
@CUPS_TRUE@cupsdir = $(libdir)/cups/backend
|
@CUPS_TRUE@cupsdir = $(libdir)/cups/backend
|
||||||
@CUPS_TRUE@profiles_cups_bluetooth_SOURCES = profiles/cups/main.c \
|
@CUPS_TRUE@profiles_cups_bluetooth_SOURCES = profiles/cups/main.c \
|
||||||
|
@@ -3841,7 +3841,7 @@ unit_tests = $(am__append_55) unit/test-
|
||||||
|
@BTPCLIENT_TRUE@tools_btpclient_DEPENDENCIES = lib/libbluetooth-internal.la $(ell_dependencies)
|
||||||
|
@BTPCLIENT_TRUE@tools_btpclientctl_SOURCES = tools/btpclientctl.c client/display.c
|
||||||
|
@BTPCLIENT_TRUE@tools_btpclientctl_LDADD = src/libshared-mainloop.la src/libshared-glib.la \
|
||||||
|
-@BTPCLIENT_TRUE@ lib/libbluetooth-internal.la -lreadline
|
||||||
|
+@BTPCLIENT_TRUE@ lib/libbluetooth-internal.la -lreadline -lncurses
|
||||||
|
|
||||||
|
|
||||||
|
# SPDX-License-Identifier: GPL-2.0
|
||||||
|
|
|
@ -1,9 +1,9 @@
|
||||||
--- a/src/shared/util.h
|
--- a/src/shared/util.h
|
||||||
+++ b/src/shared/util.h
|
+++ b/src/shared/util.h
|
||||||
@@ -14,6 +14,7 @@
|
@@ -15,6 +15,7 @@
|
||||||
#include <alloca.h>
|
|
||||||
#include <byteswap.h>
|
#include <byteswap.h>
|
||||||
#include <string.h>
|
#include <string.h>
|
||||||
|
#include <sys/types.h>
|
||||||
+#include <endian.h>
|
+#include <endian.h>
|
||||||
|
|
||||||
#define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
|
#define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
|
||||||
|
|
|
@ -34,7 +34,7 @@ This commit prevents the call to btd_adv_manager_refresh for non-LE devices.
|
||||||
|
|
||||||
--- a/src/adapter.c
|
--- a/src/adapter.c
|
||||||
+++ b/src/adapter.c
|
+++ b/src/adapter.c
|
||||||
@@ -606,7 +606,9 @@ static void settings_changed(struct btd_
|
@@ -601,7 +601,9 @@ static void settings_changed(struct btd_
|
||||||
*/
|
*/
|
||||||
if (!adapter->discovery_discoverable)
|
if (!adapter->discovery_discoverable)
|
||||||
store_adapter_info(adapter);
|
store_adapter_info(adapter);
|
||||||
|
|
Loading…
Reference in a new issue