unbound: update to 1.18.0
Signed-off-by: Eric Luehrsen <ericluehrsen@gmail.com>
This commit is contained in:
parent
c663d8171f
commit
03f70dcfd5
3 changed files with 4 additions and 41 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=unbound
|
||||
PKG_VERSION:=1.17.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.18.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://nlnetlabs.nl/downloads/unbound
|
||||
PKG_HASH:=ee4085cecce12584e600f3d814a28fa822dfaacec1f94c84bfd67f8a5571a5f4
|
||||
PKG_HASH:=3da95490a85cff6420f26fae0b84a49f5112df1bf1b7fc34f8724f02082cb712
|
||||
|
||||
PKG_MAINTAINER:=Eric Luehrsen <ericluehrsen@gmail.com>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
|
|
@ -3,7 +3,7 @@ Fix cross compile errors by inserting an environment variable for the
|
|||
target. Use "uname" on host only if "UNAME" variable is empty.
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -819,7 +819,7 @@ if test x_$ub_test_python != x_no; then
|
||||
@@ -840,7 +840,7 @@ if test x_$ub_test_python != x_no; then
|
||||
fi
|
||||
fi
|
||||
|
||||
|
|
|
@ -1,37 +0,0 @@
|
|||
--- a/util/net_help.c
|
||||
+++ b/util/net_help.c
|
||||
@@ -1005,6 +1005,16 @@ listen_sslctx_setup(void* ctxt)
|
||||
log_crypto_err("could not set cipher list with SSL_CTX_set_cipher_list");
|
||||
}
|
||||
#endif
|
||||
+#if defined(SSL_OP_IGNORE_UNEXPECTED_EOF)
|
||||
+ /* ignore errors when peers do not send the mandatory close_notify
|
||||
+ * alert on shutdown.
|
||||
+ * Relevant for openssl >= 3 */
|
||||
+ if((SSL_CTX_set_options(ctx, SSL_OP_IGNORE_UNEXPECTED_EOF) &
|
||||
+ SSL_OP_IGNORE_UNEXPECTED_EOF) != SSL_OP_IGNORE_UNEXPECTED_EOF) {
|
||||
+ log_crypto_err("could not set SSL_OP_IGNORE_UNEXPECTED_EOF");
|
||||
+ return 0;
|
||||
+ }
|
||||
+#endif
|
||||
|
||||
if((SSL_CTX_set_options(ctx, SSL_OP_CIPHER_SERVER_PREFERENCE) &
|
||||
SSL_OP_CIPHER_SERVER_PREFERENCE) !=
|
||||
@@ -1233,6 +1243,17 @@ void* connect_sslctx_create(char* key, c
|
||||
SSL_CTX_free(ctx);
|
||||
return 0;
|
||||
}
|
||||
+#endif
|
||||
+#if defined(SSL_OP_IGNORE_UNEXPECTED_EOF)
|
||||
+ /* ignore errors when peers do not send the mandatory close_notify
|
||||
+ * alert on shutdown.
|
||||
+ * Relevant for openssl >= 3 */
|
||||
+ if((SSL_CTX_set_options(ctx, SSL_OP_IGNORE_UNEXPECTED_EOF) &
|
||||
+ SSL_OP_IGNORE_UNEXPECTED_EOF) != SSL_OP_IGNORE_UNEXPECTED_EOF) {
|
||||
+ log_crypto_err("could not set SSL_OP_IGNORE_UNEXPECTED_EOF");
|
||||
+ SSL_CTX_free(ctx);
|
||||
+ return 0;
|
||||
+ }
|
||||
#endif
|
||||
if(key && key[0]) {
|
||||
if(!SSL_CTX_use_certificate_chain_file(ctx, pem)) {
|
Loading…
Reference in a new issue