commit
02fb0de9fa
4 changed files with 17 additions and 63 deletions
|
@ -1,12 +1,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=pdns
|
||||
PKG_VERSION:=4.3.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=4.4.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
|
||||
PKG_HASH:=d5146c04098ee94b9377ee491ebb3fd5eb061d7b24262f4a8e1a89f2ed3fc245
|
||||
PKG_HASH:=40cb81d9e0d34edcc7c95435a06125bde0bd1a51692e1db52413e31d7ede0b39
|
||||
|
||||
PKG_MAINTAINER:=James Taylor <james@jtaylor.id.au>
|
||||
PKG_LICENCE:=GPL-2.0-only
|
||||
|
@ -184,6 +184,7 @@ CONFIGURE_ARGS+= \
|
|||
--without-libsodium \
|
||||
--enable-experimental-pkcs11 \
|
||||
--enable-lua-records \
|
||||
--enable-reproducible \
|
||||
$(if $(CONFIG_PACKAGE_pdns-ixfrdist),--enable-ixfrdist,)
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
|
|
|
@ -1,19 +1,24 @@
|
|||
diff --git a/pdns/Makefile.am b/pdns/Makefile.am
|
||||
index 2df5fa7..2246088 100644
|
||||
--- a/pdns/Makefile.am
|
||||
+++ b/pdns/Makefile.am
|
||||
@@ -68,11 +68,9 @@ CLEANFILES = \
|
||||
backends/gsql/gsqlbackend.gcda \
|
||||
@@ -71,7 +71,6 @@ CLEANFILES = \
|
||||
backends/gsql/gsqlbackend.gcno \
|
||||
backends/gsql/gsqlbackend.gcov \
|
||||
- dnsmessage.pb.cc dnsmessage.pb.h \
|
||||
- pdns.conf-dist
|
||||
+ dnsmessage.pb.cc dnsmessage.pb.h
|
||||
dnsmessage.pb.cc dnsmessage.pb.h \
|
||||
- pdns.conf-dist \
|
||||
apidocfiles.h \
|
||||
api-swagger.yaml \
|
||||
api-swagger.json
|
||||
@@ -99,7 +98,6 @@ apidocfiles.h: api-swagger.yaml api-swagger.json
|
||||
./incfiles $^ > $@
|
||||
|
||||
noinst_SCRIPTS = pdns.init
|
||||
-sysconf_DATA = pdns.conf-dist
|
||||
|
||||
sbin_PROGRAMS = pdns_server
|
||||
bin_PROGRAMS = \
|
||||
@@ -112,7 +110,7 @@ if IXFRDIST
|
||||
@@ -139,7 +137,7 @@ if IXFRDIST
|
||||
bin_PROGRAMS += \
|
||||
ixfrdist
|
||||
|
||||
|
@ -22,12 +27,12 @@
|
|||
ixfrdist.example.yml
|
||||
endif
|
||||
|
||||
@@ -1248,9 +1246,6 @@ dnspcap2protobuf_LDADD = \
|
||||
@@ -1278,9 +1276,6 @@ dnspcap2protobuf_LDADD = \
|
||||
endif
|
||||
endif
|
||||
|
||||
-pdns.conf-dist: pdns_server
|
||||
- $(AM_V_GEN)./pdns_server --no-config --config=default 2>/dev/null > $@
|
||||
- $(AM_V_GEN)./pdns_server --config=default 2>/dev/null > $@
|
||||
-
|
||||
testrunner_SOURCES = \
|
||||
arguments.cc \
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- a/pdns/opensslsigners.cc
|
||||
+++ b/pdns/opensslsigners.cc
|
||||
@@ -29,6 +29,7 @@
|
||||
#if defined(HAVE_LIBCRYPTO_ED25519) || defined(HAVE_LIBCRYPTO_ED448)
|
||||
#include <openssl/evp.h>
|
||||
#endif
|
||||
+#include <openssl/bn.h>
|
||||
#include <openssl/sha.h>
|
||||
#include <openssl/rand.h>
|
||||
#include <openssl/rsa.h>
|
||||
--- a/pdns/pkcs11signers.cc
|
||||
+++ b/pdns/pkcs11signers.cc
|
||||
@@ -15,6 +15,7 @@
|
||||
#include "pdns/lock.hh"
|
||||
|
||||
#ifdef HAVE_LIBCRYPTO_ECDSA
|
||||
+#include <openssl/bn.h>
|
||||
#include <openssl/ec.h>
|
||||
#endif
|
||||
|
|
@ -1,32 +0,0 @@
|
|||
--- a/pdns/ixfrdist-web.cc
|
||||
+++ b/pdns/ixfrdist-web.cc
|
||||
@@ -25,6 +25,8 @@
|
||||
#include "iputils.hh"
|
||||
#include "ixfrdist-stats.hh"
|
||||
|
||||
+using namespace boost::placeholders;
|
||||
+
|
||||
string doGetStats();
|
||||
|
||||
IXFRDistWebServer::IXFRDistWebServer(const ComboAddress &listenAddress, const NetmaskGroup &acl, const string &loglevel) :
|
||||
--- a/pdns/webserver.cc
|
||||
+++ b/pdns/webserver.cc
|
||||
@@ -36,6 +36,8 @@
|
||||
#include "uuid-utils.hh"
|
||||
#include <yahttp/router.hpp>
|
||||
|
||||
+using namespace boost::placeholders;
|
||||
+
|
||||
json11::Json HttpRequest::json()
|
||||
{
|
||||
string err;
|
||||
--- a/pdns/ws-auth.cc
|
||||
+++ b/pdns/ws-auth.cc
|
||||
@@ -49,6 +49,7 @@
|
||||
#include "tsigutils.hh"
|
||||
|
||||
using json11::Json;
|
||||
+using namespace boost::placeholders;
|
||||
|
||||
extern StatBag S;
|
||||
|
Loading…
Reference in a new issue