powertop: Do not use fstack-protector on ARC
Not compatible. Instead of setting PKG_SSP, I had to do this as the powertop Makefile defines it. Use $(FPIC) instead of -fPIC to fix potential issues. Removed musl patch. Not needed anymore. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
438326179e
commit
02a4ac87c0
2 changed files with 7 additions and 23 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=powertop
|
||||
PKG_VERSION:=2.10
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://01.org/sites/default/files/downloads/
|
||||
|
@ -39,8 +39,14 @@ define Package/powertop/description
|
|||
and power management.
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
ifeq ($(CONFIG_USE_UCLIBC),y)
|
||||
TARGET_CFLAGS += -fno-stack-protector
|
||||
endif
|
||||
TARGET_LDFLAGS += $(if $(INTL_FULL),-lintl)
|
||||
|
||||
CONFIGURE_ARGS += --without-pic
|
||||
|
||||
define Package/powertop/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/powertop \
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
--- ./src/devices/devfreq.h.orig
|
||||
+++ ./src/devices/devfreq.h
|
||||
@@ -25,6 +25,7 @@
|
||||
#ifndef _INCLUDE_GUARD_DEVFREQ_H
|
||||
#define _INCLUDE_GUARD_DEVFREQ_H
|
||||
|
||||
+#include <sys/time.h>
|
||||
#include "device.h"
|
||||
#include "../parameters/parameters.h"
|
||||
|
||||
diff --git a/src/perf/perf.h b/src/perf/perf.h
|
||||
index ee072ae06d24..932588a684f9 100644
|
||||
--- a/src/perf/perf.h
|
||||
+++ b/src/perf/perf.h
|
||||
@@ -26,6 +26,7 @@
|
||||
#define _INCLUDE_GUARD_PERF_H_
|
||||
|
||||
#include <iostream>
|
||||
+#include <stdio.h>
|
||||
|
||||
|
||||
extern "C" {
|
Loading…
Reference in a new issue