ruby: bump to 2.6.1
See: https://www.ruby-lang.org/en/news/2019/01/30/ruby-2-6-1-released/ See: https://www.ruby-lang.org/en/news/2018/12/25/ruby-2-6-0-released/ New packages mirroring upstream gemification of ruby: * ruby-bundler (new) * ruby-e2mmap and ruby-ostruct (from ruby-misc) * ruby-forwardable (from ruby-patterns) * ruby-matrix and ruby-prime (from removed ruby-math) * ruby-mutex_m, ruby-sync and ruby-thwait (from ruby-multithread) * ruby-tracer (from ruby-debuglib) Added ruby-dev for building extension inside openwrt (requires cc) Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
This commit is contained in:
parent
9d931ca29c
commit
0265390c92
4 changed files with 133 additions and 60 deletions
|
@ -11,7 +11,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ruby
|
||||
PKG_VERSION:=2.5.3
|
||||
PKG_VERSION:=2.6.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
# First two numbes
|
||||
|
@ -19,7 +19,7 @@ PKG_ABI_VERSION:=$(subst $(space),.,$(wordlist 1, 2, $(subst .,$(space),$(PKG_VE
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://cache.ruby-lang.org/pub/ruby/$(PKG_ABI_VERSION)/
|
||||
PKG_HASH:=1cc9d0359a8ea35fc6111ec830d12e60168f3b9b305a3c2578357d360fcf306f
|
||||
PKG_HASH:=47b629808e9fd44ce1f760cdf3ed14875fc9b19d4f334e82e2cf25cb2898f2f2
|
||||
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
|
||||
PKG_LICENSE:=BSD-2-Clause
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
@ -175,7 +175,7 @@ $(call Package/ruby/Default)
|
|||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE+= (shared library)
|
||||
DEPENDS+= +libpthread +librt +libgmp
|
||||
DEPENDS+= +libpthread +librt +libgmp +zlib
|
||||
ABI_VERSION:=$(PKG_ABI_VERSION)
|
||||
endef
|
||||
define Package/libruby/install
|
||||
|
@ -183,6 +183,21 @@ define Package/libruby/install
|
|||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libruby.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/ruby-dev
|
||||
$(call Package/ruby/Default)
|
||||
TITLE+= (dev files)
|
||||
DEPENDS:=+libruby
|
||||
endef
|
||||
define Package/ruby-dev/description
|
||||
Header files for compiling extension modules for the Ruby $(PKG_ABI_VERSION)
|
||||
endef
|
||||
define Package/ruby-dev/install
|
||||
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/ruby-$(PKG_ABI_VERSION) $(1)/usr/include/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libruby.so $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/ruby-$(PKG_ABI_VERSION).pc $(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
RUBY_STDLIB :=
|
||||
define Package/ruby-stdlib
|
||||
$(call Package/ruby/Default)
|
||||
|
@ -204,10 +219,19 @@ endef
|
|||
|
||||
define Package/ruby-bigdecimal/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/*/bigdecimal.so
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/*/bigdecimal/
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/bigdecimal/
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/bigdecimal.rb
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/bigdecimal-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-bundler/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/bundler.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/bundler/
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/gems/bundler-*/
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/bundler-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-cgi/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/cgi
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/cgi.rb
|
||||
|
@ -221,6 +245,7 @@ endef
|
|||
|
||||
define Package/ruby-csv/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/csv.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/csv/
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/csv-*.gemspec
|
||||
endef
|
||||
|
||||
|
@ -244,7 +269,6 @@ define Package/ruby-debuglib/files
|
|||
/usr/lib/ruby/$(PKG_ABI_VERSION)/profile.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/profiler.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/debug.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/tracer.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/benchmark.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/*/objspace.so
|
||||
endef
|
||||
|
@ -300,6 +324,12 @@ define Package/ruby-enc/files
|
|||
/usr/lib/ruby/$(PKG_ABI_VERSION)/*/enc/euc_jp.so
|
||||
endef
|
||||
|
||||
define Package/ruby-e2mmap/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/e2mmap.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/e2mmap/
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/e2mmap-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-enc-extra/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/*/enc
|
||||
endef
|
||||
|
@ -339,9 +369,16 @@ endef
|
|||
|
||||
define Package/ruby-fileutils/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/fileutils.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/fileutils/
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/fileutils-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-forwardable/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/forwardable.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/forwardable
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/forwardable-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-gdbm/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/*/gdbm.so
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/gdbm-*.gemspec
|
||||
|
@ -383,6 +420,8 @@ endef
|
|||
define Package/ruby-irb/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/irb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/irb.rb
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/gems/irb-*/
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/irb-*.gemspec
|
||||
endef
|
||||
define Package/ruby-irb/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
|
@ -404,12 +443,13 @@ define Package/ruby-logger/files
|
|||
/usr/lib/ruby/$(PKG_ABI_VERSION)/logger.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/syslog/logger.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/*/syslog.so
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/logger-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-math/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/prime.rb
|
||||
define Package/ruby-matrix/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/matrix.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/matrix
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/matrix-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-minitest/files
|
||||
|
@ -426,12 +466,11 @@ define Package/ruby-misc/files
|
|||
/usr/lib/ruby/$(PKG_ABI_VERSION)/English.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/abbrev.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/base64.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/coverage.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/delegate.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/e2mmap.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/expect.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/getoptlong.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/open3.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/ostruct.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/securerandom.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/set.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/shellwords.rb
|
||||
|
@ -451,13 +490,15 @@ endef
|
|||
define Package/ruby-multithread/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/monitor.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/timeout.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/thwait.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/mutex_m.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/sync.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/*/io/wait.so
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/*/io/nonblock.so
|
||||
endef
|
||||
|
||||
define Package/ruby-mutex_m/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/mutex_m.rb
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/mutex_m-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-net/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/open-uri.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/net/*
|
||||
|
@ -491,11 +532,14 @@ define Package/ruby-optparse/files
|
|||
/usr/lib/ruby/$(PKG_ABI_VERSION)/optparse
|
||||
endef
|
||||
|
||||
define Package/ruby-ostruct/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/ostruct.rb
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/ostruct-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-patterns/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/observer.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/singleton.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/forwardable.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/forwardable
|
||||
endef
|
||||
|
||||
define Package/ruby-powerassert/files
|
||||
|
@ -512,6 +556,11 @@ define Package/ruby-prettyprint/files
|
|||
/usr/lib/ruby/$(PKG_ABI_VERSION)/prettyprint.rb
|
||||
endef
|
||||
|
||||
define Package/ruby-prime/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/prime.rb
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/prime-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-pstore/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/pstore.rb
|
||||
endef
|
||||
|
@ -571,6 +620,7 @@ endef
|
|||
|
||||
define Package/ruby-rexml/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/rexml
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/rexml-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-rinda/files
|
||||
|
@ -586,6 +636,7 @@ endef
|
|||
define Package/ruby-rss/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/rss
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/rss.rb
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/rss-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-scanf/files
|
||||
|
@ -601,6 +652,7 @@ endef
|
|||
define Package/ruby-shell/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/shell.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/shell
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/shell-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-socket/files
|
||||
|
@ -620,6 +672,11 @@ define Package/ruby-strscan/files
|
|||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/strscan-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-sync/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/sync.rb
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/sync-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-testunit/files
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/test-unit-*.gemspec
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/gems/test-unit-*
|
||||
|
@ -635,6 +692,18 @@ define Package/ruby-time/files
|
|||
/usr/lib/ruby/$(PKG_ABI_VERSION)/time.rb
|
||||
endef
|
||||
|
||||
define Package/ruby-thwait/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/thwait.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/thwait/
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/thwait-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-tracer/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/tracer.rb
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/tracer/
|
||||
/usr/lib/ruby/gems/$(PKG_ABI_VERSION)/specifications/default/tracer-*.gemspec
|
||||
endef
|
||||
|
||||
define Package/ruby-unicodenormalize/files
|
||||
/usr/lib/ruby/$(PKG_ABI_VERSION)/unicode_normalize
|
||||
endef
|
||||
|
@ -740,68 +809,78 @@ endef
|
|||
|
||||
$(eval $(call BuildPackage,libruby))
|
||||
$(eval $(call BuildPackage,ruby))
|
||||
$(eval $(call BuildPackage,ruby-dev))
|
||||
$(eval $(call RubyBuildPackage,bigdecimal,Arbitrary-precision decimal floating-point library,))
|
||||
$(eval $(call RubyBuildPackage,bundler,Manage dependencies,))
|
||||
$(eval $(call RubyBuildPackage,cgi,CGI support toolkit,+ruby-filelib +ruby-pstore +ruby-stringio))
|
||||
$(eval $(call RubyBuildPackage,cmath,Trigonometric and transcendental functions for complex numbers,))
|
||||
$(eval $(call RubyBuildPackage,csv,CSV Reading and Writing,+ruby-date +ruby-enc +ruby-misc +ruby-patterns +ruby-stringio))
|
||||
$(eval $(call RubyBuildPackage,csv,CSV Reading and Writing,+ruby-date +ruby-forwardable +ruby-misc +ruby-stringio +ruby-strscan))
|
||||
$(eval $(call RubyBuildPackage,date,Comparable module for handling dates,))
|
||||
$(eval $(call RubyBuildPackage,dbm,Wrapper for the UNIX-style Database Manager Library,+libdb47))
|
||||
$(eval $(call RubyBuildPackage,debuglib,debug library,+ruby-misc +ruby-prettyprint))
|
||||
$(eval $(call RubyBuildPackage,debuglib,debug library,+ruby-misc +ruby-prettyprint +ruby-tracer))
|
||||
$(eval $(call RubyBuildPackage,did-you-mean,did you mean? experience,+ruby-misc))
|
||||
$(eval $(call RubyBuildPackage,digest,Digest Library,+RUBY_DIGEST_USE_OPENSSL:libopenssl))
|
||||
$(eval $(call RubyBuildPackage,drb,distributed object system,+ruby-filelib +ruby-ipaddr +ruby-patterns))
|
||||
$(eval $(call RubyBuildPackage,e2mmap,custom exceptions with specific messages,))
|
||||
$(eval $(call RubyBuildPackage,enc,character re-coding library charset (small subset),))
|
||||
$(eval $(call RubyBuildPackage,enc-extra,character re-coding library charset (extra subset),+ruby-enc))
|
||||
$(eval $(call RubyBuildPackage,erb,(embedded interpreter),+ruby-cgi +ruby-strscan))
|
||||
$(eval $(call RubyBuildPackage,etc,Access to information typically stored in UNIX /etc directory,))
|
||||
$(eval $(call RubyBuildPackage,etc,Access info typically stored in /etc,))
|
||||
$(eval $(call RubyBuildPackage,fcntl,Loads constants defined in the OS fcntl.h C header file,))
|
||||
$(eval $(call RubyBuildPackage,fiddle,Libffi wrapper for Ruby,+libffi))
|
||||
$(eval $(call RubyBuildPackage,filelib,file utils library,+ruby-fileutils +ruby-misc))
|
||||
$(eval $(call RubyBuildPackage,fileutils,File utility methods for copying moving removing etc,+ruby-enc +ruby-etc))
|
||||
$(eval $(call RubyBuildPackage,fileutils,File utility methods for copying moving removing etc,+ruby-enc +ruby-etc +ruby-rbconfig))
|
||||
$(eval $(call RubyBuildPackage,forwardable,delegation of methods to a object,))
|
||||
$(eval $(call RubyBuildPackage,gdbm,Ruby extension for GNU dbm,+libgdbm))
|
||||
$(eval $(call RubyBuildPackage,gems,gems packet management,+ruby-net +ruby-rdoc))
|
||||
$(eval $(call RubyBuildPackage,gems,gems packet management,))
|
||||
$(eval $(call RubyBuildPackage,io-console,Console interface,))
|
||||
$(eval $(call RubyBuildPackage,ipaddr,Set of methods to manipulate an IP address,+ruby-socket))
|
||||
$(eval $(call RubyBuildPackage,irb,(interactive shell),+ruby-debuglib +ruby-filelib))
|
||||
$(eval $(call RubyBuildPackage,json,JSON Implementation for Ruby,+ruby-date +ruby-misc))
|
||||
$(eval $(call RubyBuildPackage,irb,(interactive shell),))
|
||||
$(eval $(call RubyBuildPackage,json,JSON Implementation for Ruby,+ruby-date +ruby-ostruct))
|
||||
$(eval $(call RubyBuildPackage,logger,logger and syslog library,+ruby-multithread))
|
||||
$(eval $(call RubyBuildPackage,math,math library,+ruby-patterns +ruby-misc))
|
||||
$(eval $(call RubyBuildPackage,minitest,Gem minitest,+ruby-gems))
|
||||
$(eval $(call RubyBuildPackage,matrix,implementation of Matrix and Vector classes,+ruby-e2mmap))
|
||||
$(eval $(call RubyBuildPackage,minitest,Gem minitest,+ruby-mutex_m))
|
||||
$(eval $(call RubyBuildPackage,misc,standard libraries subset (miscellaneous files),))
|
||||
$(eval $(call RubyBuildPackage,mkmf,makefile library,+ruby-filelib +ruby-optparse +ruby-rbconfig))
|
||||
$(eval $(call RubyBuildPackage,mkmf,makefile library,+ruby-filelib +ruby-optparse))
|
||||
$(eval $(call RubyBuildPackage,multithread,multithread library,+ruby-misc))
|
||||
$(eval $(call RubyBuildPackage,mutex_m,extend objects to be handled like a Mutex,))
|
||||
$(eval $(call RubyBuildPackage,net,Network Protocols Library,+ruby-time +ruby-digest +ruby-filelib +ruby-socket +ruby-stringio +ruby-strscan +ruby-uri))
|
||||
$(eval $(call RubyBuildPackage,net-telnet,telnet client,+ruby-net))
|
||||
$(eval $(call RubyBuildPackage,nkf,Network Kanji Filter,+ruby-enc))
|
||||
$(eval $(call RubyBuildPackage,openssl,SSL TLS and general purpose cryptography,+ruby-enc +ruby-multithread +ruby-stringio +libopenssl))
|
||||
$(eval $(call RubyBuildPackage,openssl,SSL TLS and general purpose cryptography,+ruby-enc +ruby-ipaddr +ruby-stringio +libopenssl))
|
||||
$(eval $(call RubyBuildPackage,ostruct,build custom data structures,))
|
||||
$(eval $(call RubyBuildPackage,optparse,command-line option analysis,+ruby-misc +ruby-time))
|
||||
$(eval $(call RubyBuildPackage,patterns,design patterns implementation,))
|
||||
$(eval $(call RubyBuildPackage,powerassert,Gem power_assert,+ruby-prettyprint +ruby-ripper))
|
||||
$(eval $(call RubyBuildPackage,prettyprint,PrettyPrint library,+ruby-etc))
|
||||
$(eval $(call RubyBuildPackage,prime,Prime numbers and factorization library,+ruby-forwardable +ruby-patterns))
|
||||
$(eval $(call RubyBuildPackage,pstore,file based persistence,+ruby-digest +ruby-enc))
|
||||
$(eval $(call RubyBuildPackage,psych,YAML parser and emitter,+ruby-bigdecimal +ruby-date +ruby-enc +ruby-stringio +ruby-strscan +libyaml))
|
||||
$(eval $(call RubyBuildPackage,racc,LALR parser generator,))
|
||||
$(eval $(call RubyBuildPackage,rake,Rake (make replacement),+ruby-fileutils +ruby-multithread +ruby-optparse +ruby-patterns +ruby-rbconfig))
|
||||
$(eval $(call RubyBuildPackage,rake,Rake (make replacement),+ruby-fileutils +ruby-multithread +ruby-optparse +ruby-ostruct +ruby-patterns))
|
||||
$(eval $(call RubyBuildPackage,rbconfig,RbConfig,))
|
||||
$(eval $(call RubyBuildPackage,rdoc,RDoc produces HTML and command-line documentation for Ruby projects,+ruby-debuglib +ruby-did-you-mean +ruby-erb +ruby-json +ruby-racc +ruby-rake +ruby-ripper +ruby-yaml +ruby-zlib))
|
||||
$(eval $(call RubyBuildPackage,readline,support for readline,+libncurses +libreadline))
|
||||
$(eval $(call RubyBuildPackage,rexml,XML toolkit,+ruby-enc +ruby-misc +ruby-patterns +ruby-stringio))
|
||||
$(eval $(call RubyBuildPackage,rinda,Linda paradigm implementation,+ruby-drb))
|
||||
$(eval $(call RubyBuildPackage,rexml,XML toolkit,+ruby-enc +ruby-forwardable +ruby-misc +ruby-stringio +ruby-strscan))
|
||||
$(eval $(call RubyBuildPackage,rinda,Linda paradigm implementation,+ruby-drb +ruby-forwardable))
|
||||
$(eval $(call RubyBuildPackage,ripper,script parser,))
|
||||
$(eval $(call RubyBuildPackage,rss,RSS toolkit,+ruby-net +ruby-nkf +ruby-rexml))
|
||||
$(eval $(call RubyBuildPackage,scanf,Implementation of the C function scanf(3),))
|
||||
$(eval $(call RubyBuildPackage,sdbm,simple file-based key-value dbm implementation,))
|
||||
$(eval $(call RubyBuildPackage,shell,idiomatic Ruby interface,+ruby-patterns +ruby-multithread))
|
||||
$(eval $(call RubyBuildPackage,socket,socket support,+ruby-multithread))
|
||||
$(eval $(call RubyBuildPackage,shell,idiomatic Ruby interface,+ruby-e2mmap +ruby-forwardable +ruby-sync))
|
||||
$(eval $(call RubyBuildPackage,socket,socket support,+ruby-misc +ruby-multithread))
|
||||
$(eval $(call RubyBuildPackage,stringio,Pseudo `IO` class from/to `String`,))
|
||||
$(eval $(call RubyBuildPackage,strscan,Lexical scanning operations on a String,))
|
||||
$(eval $(call RubyBuildPackage,sync,two-phase lock with a counter,))
|
||||
$(eval $(call RubyBuildPackage,testunit,Gem test-unit,+ruby-csv +ruby-erb +ruby-optparse +ruby-powerassert +ruby-rexml +ruby-yaml))
|
||||
$(eval $(call RubyBuildPackage,time,Extends Time with additional methods for parsing and converting Times,+ruby-date))
|
||||
$(eval $(call RubyBuildPackage,thwait,Watches for termination of multiple threads,+ruby-e2mmap))
|
||||
$(eval $(call RubyBuildPackage,tracer,Outputs a source level execution trace of a Ruby program,))
|
||||
$(eval $(call RubyBuildPackage,unicodenormalize,String additions for Unicode normalization,+ruby-enc +ruby-enc-extra))
|
||||
$(eval $(call RubyBuildPackage,uri,library to handle URI,+ruby-enc))
|
||||
$(eval $(call RubyBuildPackage,webrick,HTTP server toolkit,+ruby-erb +ruby-net +ruby-patterns +ruby-rbconfig))
|
||||
$(eval $(call RubyBuildPackage,webrick,HTTP server toolkit,+ruby-erb +ruby-net +ruby-patterns))
|
||||
$(eval $(call RubyBuildPackage,xmlrpc,XML-RPC toolkit,+ruby-rexml +ruby-webrick))
|
||||
$(eval $(call RubyBuildPackage,yaml,YAML toolkit,+ruby-dbm +ruby-pstore +ruby-psych))
|
||||
$(eval $(call RubyBuildPackage,zlib,compression/decompression library interface,+zlib))
|
||||
$(eval $(call RubyBuildPackage,zlib,compression/decompression library interface,))
|
||||
$(eval $(call BuildPackage,ruby-stdlib))
|
||||
$(eval $(call HostBuild))
|
||||
|
|
|
@ -1,5 +1,3 @@
|
|||
Backported to 2.5.3
|
||||
|
||||
From 74f94b3e6ebf15b76f3b357e754095412b006e94 Mon Sep 17 00:00:00 2001
|
||||
From: nobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
|
||||
Date: Fri, 8 Feb 2019 07:22:55 +0000
|
||||
|
@ -15,9 +13,19 @@ git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@67036 b2dd03c8-39d4-4d8f-98ff-
|
|||
3 files changed, 18 insertions(+), 9 deletions(-)
|
||||
create mode 100644 tool/m4/ruby_replace_funcs.m4
|
||||
|
||||
--- a/aclocal.m4
|
||||
+++ b/aclocal.m4
|
||||
@@ -35,6 +35,7 @@ m4_include([tool/m4/ruby_func_attribute.
|
||||
m4_include([tool/m4/ruby_mingw32.m4])
|
||||
m4_include([tool/m4/ruby_prepend_option.m4])
|
||||
m4_include([tool/m4/ruby_prog_gnu_ld.m4])
|
||||
+m4_include([tool/m4/ruby_replace_funcs.m4])
|
||||
m4_include([tool/m4/ruby_replace_type.m4])
|
||||
m4_include([tool/m4/ruby_rm_recursive.m4])
|
||||
m4_include([tool/m4/ruby_setjmp_type.m4])
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1189,9 +1189,6 @@ main()
|
||||
@@ -946,9 +946,6 @@ main()
|
||||
ac_cv_func_fsync=yes
|
||||
ac_cv_func_seekdir=yes
|
||||
ac_cv_func_telldir=yes
|
||||
|
@ -27,7 +35,7 @@ git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@67036 b2dd03c8-39d4-4d8f-98ff-
|
|||
ac_cv_func_lchown=yes
|
||||
ac_cv_func_link=yes
|
||||
ac_cv_func_readlink=yes
|
||||
@@ -1239,9 +1236,6 @@ main()
|
||||
@@ -999,9 +996,6 @@ main()
|
||||
[netbsd*], [ LIBS="-lm $LIBS"
|
||||
],
|
||||
[dragonfly*], [ LIBS="-lm $LIBS"
|
||||
|
@ -37,7 +45,7 @@ git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@67036 b2dd03c8-39d4-4d8f-98ff-
|
|||
],
|
||||
[aix*],[ LIBS="-lm $LIBS"
|
||||
ac_cv_func_round=no
|
||||
@@ -2212,11 +2206,8 @@ AC_REPLACE_FUNCS(dup2)
|
||||
@@ -1724,11 +1718,8 @@ AC_REPLACE_FUNCS(dup2)
|
||||
AC_REPLACE_FUNCS(erf)
|
||||
AC_REPLACE_FUNCS(explicit_bzero)
|
||||
AC_REPLACE_FUNCS(ffs)
|
||||
|
@ -48,8 +56,8 @@ git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@67036 b2dd03c8-39d4-4d8f-98ff-
|
|||
-AC_REPLACE_FUNCS(isnan)
|
||||
AC_REPLACE_FUNCS(lgamma_r)
|
||||
AC_REPLACE_FUNCS(memmove)
|
||||
AC_REPLACE_FUNCS(nextafter)
|
||||
@@ -2228,6 +2219,10 @@ AC_REPLACE_FUNCS(strlcpy)
|
||||
AC_REPLACE_FUNCS(nan)
|
||||
@@ -1741,6 +1732,10 @@ AC_REPLACE_FUNCS(strlcpy)
|
||||
AC_REPLACE_FUNCS(strstr)
|
||||
AC_REPLACE_FUNCS(tgamma)
|
||||
|
||||
|
@ -76,23 +84,3 @@ git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@67036 b2dd03c8-39d4-4d8f-98ff-
|
|||
+AC_DEFUN([RUBY_REPLACE_FUNCS] [dnl
|
||||
+ m4_map_args_w([$1], [RUBY_REPLACE_FUNC(], [), [$2]])dnl
|
||||
+])
|
||||
--- a/acinclude.m4
|
||||
+++ b/acinclude.m4
|
||||
@@ -44,3 +44,17 @@ AC_DEFUN([AC_MSG_RESULT], [dnl
|
||||
{ _AS_ECHO_LOG([result: $1])
|
||||
COLORIZE_RESULT([$1]); dnl
|
||||
}])
|
||||
+
|
||||
+# -*- Autoconf -*-
|
||||
+dnl RUBY_REPLACE_FUNC [func] [included]
|
||||
+AC_DEFUN([RUBY_REPLACE_FUNC], [dnl
|
||||
+ AC_CHECK_DECL([$1],dnl
|
||||
+ [AC_DEFINE(AS_TR_CPP(HAVE_[$1]))],dnl
|
||||
+ [AC_REPLACE_FUNCS($1)],dnl
|
||||
+ [$2])dnl
|
||||
+])
|
||||
+
|
||||
+dnl RUBY_REPLACE_FUNCS [funcs] [included]
|
||||
+AC_DEFUN([RUBY_REPLACE_FUNCS] [dnl
|
||||
+ m4_map_args_w([$1], [RUBY_REPLACE_FUNC(], [), [$2]])dnl
|
||||
+])
|
||||
|
|
|
@ -26,7 +26,7 @@ require_ignore=%w{drb/invokemethod16 foo rubygems/defaults/operating_system win3
|
|||
builder/xchar json/pure simplecov win32/sspi rdoc/markdown/literals_1_8 enumerator win32/resolv rbtree
|
||||
nqxml/streamingparser nqxml/treeparser xmlscan/parser xmlscan/scanner xmltreebuilder xml/parser xmlparser xml/encoding-ja xmlencoding-ja
|
||||
iconv uconv win32ole gettext/po_parser gettext/mo libxml psych.jar psych_jars jar-dependencies thread minitest/proveit
|
||||
bundler pry
|
||||
bundler pry bcrypt net/http/pipeline capistrano/version rubygems/builder rubygems/format diff/lcs graphviz
|
||||
}
|
||||
|
||||
builtin_enc=[
|
||||
|
|
|
@ -32,10 +32,16 @@ function list_ipkg_files {
|
|||
}
|
||||
|
||||
|
||||
echo " Installed in Staging Packages"
|
||||
|
||||
set -e
|
||||
: ${1:?First arg is staging_dir}
|
||||
: ${2:?Second and following args are ruby ipkg packages}
|
||||
STAGING_DIR=$1; shift
|
||||
(cd "$STAGING_DIR" )
|
||||
if ! [ -e "$1" ]; then
|
||||
echo "$1 does not exist!"
|
||||
exit 1
|
||||
fi
|
||||
printf '%-62s %-62s\n' "Installed in Staging" "From Packages Files"
|
||||
diff -d -y <(list_staging_files "$STAGING_DIR") <(list_ipkg_files "$@")
|
||||
|
||||
|
|
Loading…
Reference in a new issue