getdns: bump to 1.7.0
Remove obsolete patches. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
This commit is contained in:
parent
c038c363d7
commit
0261cd0972
5 changed files with 3 additions and 97 deletions
|
@ -5,8 +5,8 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=getdns
|
||||
PKG_VERSION:=1.6.0
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=1.7.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
@ -14,7 +14,7 @@ PKG_MAINTAINER:=Jonathan Underwood <jonathan.underwood@gmail.com>
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://getdnsapi.net/dist/
|
||||
PKG_HASH:=40e5737471a3902ba8304b0fd63aa7c95802f66ebbc6eae53c487c8e8a380f4a
|
||||
PKG_HASH:=ea8713ce5e077ac76b1418ceb6afd25e6d4e39e9600f6f5e81d3a3a13a60f652
|
||||
|
||||
CMAKE_INSTALL:=1
|
||||
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- a/src/tls/val_secalgo.c
|
||||
+++ b/src/tls/val_secalgo.c
|
||||
@@ -72,6 +72,10 @@
|
||||
#include <openssl/engine.h>
|
||||
#endif
|
||||
|
||||
+#ifdef USE_DSA
|
||||
+#include <openssl/dsa.h>
|
||||
+#endif
|
||||
+
|
||||
/** fake DSA support for unit tests */
|
||||
int fake_dsa = 0;
|
||||
/** fake SHA1 support for unit tests */
|
|
@ -1,57 +0,0 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -334,6 +334,9 @@ check_include_file(openssl/err.h HAVE_OP
|
||||
check_include_file(openssl/rand.h HAVE_OPENSSL_RAND_H)
|
||||
check_include_file(openssl/conf.h HAVE_OPENSSL_CONF_H)
|
||||
check_include_file(openssl/engine.h HAVE_OPENSSL_ENGINE_H)
|
||||
+check_include_file(openssl/bn.h HAVE_OPENSSL_BN_H)
|
||||
+check_include_file(openssl/dsa.h HAVE_OPENSSL_DSA_H)
|
||||
+check_include_file(openssl/rsa.h HAVE_OPENSSL_RSA_H)
|
||||
|
||||
set(CMAKE_REQUIRED_LIBRARIES ${OPENSSL_LIBRARIES})
|
||||
check_function_exists(DSA_SIG_set0 HAVE_DSA_SIG_SET0)
|
||||
--- a/cmake/include/cmakeconfig.h.in
|
||||
+++ b/cmake/include/cmakeconfig.h.in
|
||||
@@ -58,6 +58,9 @@
|
||||
#cmakedefine HAVE_OPENSSL_RAND_H 1
|
||||
#cmakedefine HAVE_OPENSSL_CONF_H 1
|
||||
#cmakedefine HAVE_OPENSSL_ENGINE_H 1
|
||||
+#cmakedefine HAVE_OPENSSL_BN_H 1
|
||||
+#cmakedefine HAVE_OPENSSL_DSA_H 1
|
||||
+#cmakedefine HAVE_OPENSSL_RSA_H 1
|
||||
|
||||
#cmakedefine HAVE_DSA_SIG_SET0 1
|
||||
#cmakedefine HAVE_DSA_SET0_PQG 1
|
||||
--- a/src/openssl/keyraw-internal.c
|
||||
+++ b/src/openssl/keyraw-internal.c
|
||||
@@ -21,10 +21,10 @@
|
||||
#include <openssl/err.h>
|
||||
#include <openssl/md5.h>
|
||||
#ifdef HAVE_OPENSSL_CONF_H
|
||||
-# include <openssl/conf.h>
|
||||
+#include <openssl/conf.h>
|
||||
#endif
|
||||
#ifdef HAVE_OPENSSL_ENGINE_H
|
||||
-# include <openssl/engine.h>
|
||||
+#include <openssl/engine.h>
|
||||
#endif
|
||||
#ifdef HAVE_OPENSSL_BN_H
|
||||
#include <openssl/bn.h>
|
||||
@@ -35,6 +35,9 @@
|
||||
#ifdef HAVE_OPENSSL_DSA_H
|
||||
#include <openssl/dsa.h>
|
||||
#endif
|
||||
+#ifdef HAVE_OPENSSL_RSA_H
|
||||
+#include <openssl/rsa.h>
|
||||
+#endif
|
||||
#endif /* HAVE_SSL */
|
||||
|
||||
#ifdef HAVE_SSL
|
||||
@@ -74,7 +77,6 @@ gldns_key_EVP_load_gost_id(void)
|
||||
if(!e) {
|
||||
/* load it ourself, in case statically linked */
|
||||
ENGINE_load_builtin_engines();
|
||||
- ENGINE_load_dynamic();
|
||||
e = ENGINE_by_id("gost");
|
||||
}
|
||||
if(!e) {
|
|
@ -1,13 +0,0 @@
|
|||
--- a/cmake/include/cmakeconfig.h.in
|
||||
+++ b/cmake/include/cmakeconfig.h.in
|
||||
@@ -91,8 +91,8 @@
|
||||
#cmakedefine HAVE_OPENSSL_VERSION 1
|
||||
|
||||
#cmakedefine HAVE_SSL_CTX_DANE_ENABLE 1
|
||||
-#cmakedefine HAVE_SSL_CTX_SET_CIPHERSUITS 1
|
||||
-#cmakedefine HAVE_SSL_SET_CIPHERSUITS 1
|
||||
+#cmakedefine HAVE_SSL_CTX_SET_CIPHERSUITES 1
|
||||
+#cmakedefine HAVE_SSL_SET_CIPHERSUITES 1
|
||||
|
||||
#cmakedefine HAVE_OPENSSL_INIT_CRYPTO 1
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -523,7 +523,7 @@ set(STRPTIME_TEST_SOURCE "\n
|
||||
res = strptime(\"20070207111842\", \"%Y%m%d%H%M%S\", &tm);\n
|
||||
if (!res) return 1; return 0; }")
|
||||
|
||||
-if (HAVE_STRPTIME)
|
||||
+if (HAVE_STRPTIME AND NOT CMAKE_CROSSCOMPILING)
|
||||
check_c_source_runs("${STRPTIME_TEST_SOURCE}" STRPTIME_WORKS)
|
||||
endif ()
|
||||
|
Loading…
Reference in a new issue