protobuf: update to 3.15.6
Remove upstreamed patch.
Switch to AUTORELEASE for simplicity.
Switch to building with Ninja for faster compilation.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit 1d0d8e057c
)
This commit is contained in:
parent
4ebb81b254
commit
022aef6add
2 changed files with 4 additions and 39 deletions
|
@ -8,25 +8,23 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=protobuf
|
PKG_NAME:=protobuf
|
||||||
PKG_VERSION:=3.14.0
|
PKG_VERSION:=3.15.6
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-cpp-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-cpp-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/google/protobuf/releases/download/v$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/google/protobuf/releases/download/v$(PKG_VERSION)
|
||||||
PKG_HASH:=50ec5a07c0c55d4ec536dd49021f2e194a26bfdbc531d03d1e9d4d3e27175659
|
PKG_HASH:=bbdfb7455431d7d58666e8a2996d14b236718ff238eecde10646581e4c87f168
|
||||||
|
|
||||||
PKG_MAINTAINER:=Ken Keys <kkeys@caida.org>
|
PKG_MAINTAINER:=Ken Keys <kkeys@caida.org>
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
PKG_CPE_ID:=cpe:/a:google:protobuf
|
PKG_CPE_ID:=cpe:/a:google:protobuf
|
||||||
|
|
||||||
HOST_BUILD_PARALLEL:=1
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
|
||||||
CMAKE_SOURCE_SUBDIR:=cmake
|
CMAKE_SOURCE_SUBDIR:=cmake
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
include $(INCLUDE_DIR)/cmake.mk
|
include ../../devel/ninja/ninja-cmake.mk
|
||||||
|
|
||||||
define Package/protobuf/Default
|
define Package/protobuf/Default
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
|
|
|
@ -1,33 +0,0 @@
|
||||||
From db2c4f357432ee18975a69af71f50ed415584829 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rosen Penev <rosenp@gmail.com>
|
|
||||||
Date: Thu, 17 Dec 2020 20:54:48 -0800
|
|
||||||
Subject: [PATCH] remove CMAKE_THREAD_LIBS_INIT from pkgconfig CFLAGS
|
|
||||||
|
|
||||||
This is a linker flag and does not belong in CFLAGS.
|
|
||||||
|
|
||||||
Fixes an issue with ola and protobuf.
|
|
||||||
|
|
||||||
Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
|
||||||
---
|
|
||||||
cmake/protobuf-lite.pc.cmake | 2 +-
|
|
||||||
cmake/protobuf.pc.cmake | 2 +-
|
|
||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
--- a/cmake/protobuf-lite.pc.cmake
|
|
||||||
+++ b/cmake/protobuf-lite.pc.cmake
|
|
||||||
@@ -7,5 +7,5 @@ Name: Protocol Buffers
|
|
||||||
Description: Google's Data Interchange Format
|
|
||||||
Version: @protobuf_VERSION@
|
|
||||||
Libs: -L${libdir} -lprotobuf-lite @CMAKE_THREAD_LIBS_INIT@
|
|
||||||
-Cflags: -I${includedir} @CMAKE_THREAD_LIBS_INIT@
|
|
||||||
+Cflags: -I${includedir}
|
|
||||||
Conflicts: protobuf
|
|
||||||
--- a/cmake/protobuf.pc.cmake
|
|
||||||
+++ b/cmake/protobuf.pc.cmake
|
|
||||||
@@ -7,5 +7,5 @@ Name: Protocol Buffers
|
|
||||||
Description: Google's Data Interchange Format
|
|
||||||
Version: @protobuf_VERSION@
|
|
||||||
Libs: -L${libdir} -lprotobuf @CMAKE_THREAD_LIBS_INIT@
|
|
||||||
-Cflags: -I${includedir} @CMAKE_THREAD_LIBS_INIT@
|
|
||||||
+Cflags: -I${includedir}
|
|
||||||
Conflicts: protobuf-lite
|
|
Loading…
Reference in a new issue