icu: bump to 73.1
Description: It updates to CLDR 43 locale data with various additions and corrections. ICU 73 improves Japanese and Korean short-text line breaking, reduces C++ memory use in date formatting, and promotes the Java person name formatter from tech preview to draft. ICU 73 and CLDR 43 are minor releases, mostly focused on bug fixes and small enhancements. (The fall CLDR/ICU releases will update to Unicode 15.1 which is planned for September.) ICU 73 updates to the time zone data version 2023c (2023-mar). Note that pre-1970 data for a number of time zones has been removed, as has been the case in the upstream tzdata release since 2021b. Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
This commit is contained in:
parent
1f9baddd43
commit
018fcf3ccd
2 changed files with 8 additions and 7 deletions
|
@ -8,14 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=icu4c
|
||||
MAJOR_VERSION:=72
|
||||
MAJOR_VERSION:=73
|
||||
MINOR_VERSION:=1
|
||||
PKG_VERSION:=$(MAJOR_VERSION).$(MINOR_VERSION)
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(MAJOR_VERSION)_$(MINOR_VERSION)-src.tgz
|
||||
PKG_SOURCE_URL:=https://github.com/unicode-org/icu/releases/download/release-$(MAJOR_VERSION)-$(MINOR_VERSION)
|
||||
PKG_HASH:=a2d2d38217092a7ed56635e34467f92f976b370e20182ad325edea6681a71d68
|
||||
PKG_HASH:=a457431de164b4aa7eca00ed134d00dfbf88a77c6986a10ae7774fc076bb8c45
|
||||
|
||||
PKG_LICENSE:=ICU
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
@ -25,6 +25,7 @@ PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>
|
|||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
HOST_BUILD_PARALLEL:=1
|
||||
|
||||
PKG_BUILD_DEPENDS:=icu/host
|
||||
HOST_BUILD_DEPENDS:=python3/host
|
||||
|
|
|
@ -29,7 +29,7 @@
|
|||
*pErrorCode=U_MEMORY_ALLOCATION_ERROR;
|
||||
--- a/common/utext.cpp
|
||||
+++ b/common/utext.cpp
|
||||
@@ -569,7 +569,7 @@ enum {
|
||||
@@ -572,7 +572,7 @@ enum {
|
||||
|
||||
struct ExtendedUText {
|
||||
UText ut;
|
||||
|
@ -38,7 +38,7 @@
|
|||
};
|
||||
|
||||
static const UText emptyText = UTEXT_INITIALIZER;
|
||||
@@ -584,7 +584,7 @@ utext_setup(UText *ut, int32_t extraSpac
|
||||
@@ -587,7 +587,7 @@ utext_setup(UText *ut, int32_t extraSpac
|
||||
// We need to heap-allocate storage for the new UText
|
||||
int32_t spaceRequired = sizeof(UText);
|
||||
if (extraSpace > 0) {
|
||||
|
@ -46,7 +46,7 @@
|
|||
+ spaceRequired = sizeof(ExtendedUText) + extraSpace - sizeof(max_align_t);
|
||||
}
|
||||
ut = (UText *)uprv_malloc(spaceRequired);
|
||||
if (ut == NULL) {
|
||||
if (ut == nullptr) {
|
||||
--- a/tools/toolutil/toolutil.cpp
|
||||
+++ b/tools/toolutil/toolutil.cpp
|
||||
@@ -267,7 +267,7 @@ struct UToolMemory {
|
||||
|
|
Loading…
Reference in a new issue