sstp-client: update to 1.0.15
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
9477468efe
commit
013af3ff18
2 changed files with 5 additions and 5 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sstp-client
|
||||
PKG_VERSION:=1.0.13
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=1.0.15
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/sstp-client/$(PKG_VERSION)
|
||||
PKG_HASH:=961258fca0795d8ad60b047942cf7cb53d025d353fd1e4ba08c2b75799f5321b
|
||||
PKG_HASH:=8484aa51fbfbe418a0ebad58ad20a8ee1c46ed71f800be18bcd23b42e6baad64
|
||||
|
||||
PKG_MAINTAINER:=Federico Di Marco <fededim@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/sstp-client.c
|
||||
+++ b/src/sstp-client.c
|
||||
@@ -477,6 +477,7 @@ static status_t sstp_init_ssl(sstp_clien
|
||||
@@ -542,6 +542,7 @@ static status_t sstp_init_ssl(sstp_clien
|
||||
int retval = SSTP_FAIL;
|
||||
int status = 0;
|
||||
|
||||
|
@ -8,7 +8,7 @@
|
|||
/* Initialize the OpenSSL library */
|
||||
status = SSL_library_init();
|
||||
if (status != 1)
|
||||
@@ -490,6 +491,9 @@ static status_t sstp_init_ssl(sstp_clien
|
||||
@@ -555,6 +556,9 @@ static status_t sstp_init_ssl(sstp_clien
|
||||
|
||||
/* Create a new crypto context */
|
||||
client->ssl_ctx = SSL_CTX_new(SSLv23_client_method());
|
||||
|
|
Loading…
Reference in a new issue