lxc: bump version to 1.1.3
Signed-off-by: Marko Ratkaj <marko.ratkaj@sartura.hr>
This commit is contained in:
parent
5b2245131b
commit
00e774f374
3 changed files with 15 additions and 14 deletions
|
@ -8,15 +8,15 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=lxc
|
PKG_NAME:=lxc
|
||||||
PKG_VERSION:=1.1.2
|
PKG_VERSION:=1.1.3
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_LICENSE:=LGPL-2.1+ BSD-2-Clause GPL-2.0
|
PKG_LICENSE:=LGPL-2.1+ BSD-2-Clause GPL-2.0
|
||||||
PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
|
PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://linuxcontainers.org/downloads/lxc/
|
PKG_SOURCE_URL:=http://linuxcontainers.org/downloads/lxc/
|
||||||
PKG_MD5SUM:=3ebadacf5fe8bfe689fd7a09812b682c
|
PKG_MD5SUM:=197abb5a28ab0b689c737eb1951023fb
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=lua
|
PKG_BUILD_DEPENDS:=lua
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/src/lxc/monitor.c
|
|
||||||
+++ b/src/lxc/monitor.c
|
|
||||||
@@ -181,7 +181,7 @@ int lxc_monitor_sock_name(const char *lx
|
|
||||||
int lxc_monitor_open(const char *lxcpath)
|
|
||||||
{
|
|
||||||
struct sockaddr_un addr;
|
|
||||||
- int fd,ret;
|
|
||||||
+ int fd,ret = 0;
|
|
||||||
int retry,backoff_ms[] = {10, 50, 100};
|
|
||||||
size_t len;
|
|
||||||
|
|
12
utils/lxc/patches/035-fix-undefined-lfd.patch
Normal file
12
utils/lxc/patches/035-fix-undefined-lfd.patch
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
--- a/src/lxc/bdev.c
|
||||||
|
+++ b/src/lxc/bdev.c
|
||||||
|
@@ -1936,3 +1936,3 @@ static int loop_mount(struct bdev *bdev)
|
||||||
|
{
|
||||||
|
- int lfd, ffd = -1, ret = -1;
|
||||||
|
+ int lfd = -1, ffd = -1, ret = -1;
|
||||||
|
struct loop_info64 lo;
|
||||||
|
@@ -1974,3 +1974,3 @@ out:
|
||||||
|
if (ret < 0) {
|
||||||
|
- close(lfd);
|
||||||
|
+ if (lfd > -1) close(lfd);
|
||||||
|
bdev->lofd = -1;
|
Loading…
Reference in a new issue