Merge pull request #8897 from neheb/boos

boost: Fix uClibc-ng compilation again
This commit is contained in:
Rosen Penev 2019-05-05 11:36:04 -07:00 committed by GitHub
commit 0098c45fdd
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 22 additions and 1 deletions

View file

@ -13,7 +13,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=boost PKG_NAME:=boost
PKG_VERSION:=1.70.0 PKG_VERSION:=1.70.0
PKG_SOURCE_VERSION:=1_70_0 PKG_SOURCE_VERSION:=1_70_0
PKG_RELEASE:=2 PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/ PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/

View file

@ -0,0 +1,21 @@
--- a/boost/math/tools/roots.hpp
+++ b/boost/math/tools/roots.hpp
@@ -665,8 +665,8 @@ namespace detail
inline T discriminant(T const & a, T const & b, T const & c)
{
T w = 4*a*c;
- T e = std::fma(-c, 4*a, w);
- T f = std::fma(b, b, -w);
+ T e = fma(-c, 4*a, w);
+ T f = fma(b, b, -w);
return f + e;
}
}
@@ -674,7 +674,6 @@ namespace detail
template<class T>
auto quadratic_roots(T const& a, T const& b, T const& c)
{
- using std::copysign;
using std::sqrt;
if constexpr (std::is_integral<T>::value)
{