gstreamer1: update to 1.17.2
Added gettext-full host dependency. Normally it comes wth glib2, but in the update to 2.65, it goes away. Add it here. Refresh patch. Add one for systems lacking distutils. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
11c2d4d21c
commit
0001f9fcf6
3 changed files with 16 additions and 5 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=gstreamer1
|
PKG_NAME:=gstreamer1
|
||||||
PKG_VERSION:=1.17.1
|
PKG_VERSION:=1.17.2
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=gstreamer-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=gstreamer-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gstreamer
|
PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gstreamer
|
||||||
PKG_HASH:=f63566152755aab98414feb859ea8b00d3b07cad2486f304a8feec1265e5aa0e
|
PKG_HASH:=0163bb2c086759411b686526e7d8f4b22efc4ac02ddf3941f66b14949f106eef
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/gstreamer-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/gstreamer-$(PKG_VERSION)
|
||||||
|
|
||||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
|
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
|
||||||
|
@ -23,7 +23,7 @@ PKG_LICENSE_FILES:=COPYING
|
||||||
PKG_CPE_ID:=cpe:/a:gstreamer_project:gstreamer
|
PKG_CPE_ID:=cpe:/a:gstreamer_project:gstreamer
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_DEPENDS:=meson/host glib2/host
|
PKG_BUILD_DEPENDS:=meson/host glib2/host gettext-full/host
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include $(INCLUDE_DIR)/nls.mk
|
include $(INCLUDE_DIR)/nls.mk
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
--- a/gst/gstplugin.c
|
--- a/gst/gstplugin.c
|
||||||
+++ b/gst/gstplugin.c
|
+++ b/gst/gstplugin.c
|
||||||
@@ -777,15 +777,8 @@ _priv_gst_plugin_load_file_for_registry (const gchar * filename,
|
@@ -790,15 +790,8 @@ _priv_gst_plugin_load_file_for_registry (const gchar * filename,
|
||||||
goto return_error;
|
|
||||||
}
|
}
|
||||||
|
#endif
|
||||||
|
|
||||||
- flags = G_MODULE_BIND_LOCAL;
|
- flags = G_MODULE_BIND_LOCAL;
|
||||||
- /* libgstpython.so is the gst-python plugin loader. It needs to be loaded with
|
- /* libgstpython.so is the gst-python plugin loader. It needs to be loaded with
|
||||||
|
|
11
multimedia/gstreamer1/patches/020-distutils.patch
Normal file
11
multimedia/gstreamer1/patches/020-distutils.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/meson.build
|
||||||
|
+++ b/meson.build
|
||||||
|
@@ -505,7 +505,7 @@ if get_option('default_library') == 'static'
|
||||||
|
endif
|
||||||
|
|
||||||
|
# Used in gst/parse/meson.build and below
|
||||||
|
-python3 = import('python').find_installation()
|
||||||
|
+python3 = 'python3'
|
||||||
|
|
||||||
|
bashcomp_option = get_option('bash-completion')
|
||||||
|
bashcomp_dep = dependency('bash-completion', version : '>= 2.0', required : bashcomp_option)
|
Loading…
Reference in a new issue